Snap for 10453563 from 5b2b7b3a556b743672b9383ed314e5b7b98322e8 to mainline-art-release

Change-Id: I3312e6406e2416651717de5b8ab7ef418f3586a9
diff --git a/Android.bp b/Android.bp
index 8c33b28..a3fab20 100644
--- a/Android.bp
+++ b/Android.bp
@@ -1,35 +1,15 @@
 package {
+    // See: http://go/android-license-faq
+    // A large-scale-change added 'default_applicable_licenses' to import
+    // all of the 'license_kinds' from "external_openwrt-prebuilts_license"
+    // to get the below license kinds:
+    //   SPDX-license-identifier-Apache-2.0
+    //   SPDX-license-identifier-BSD
+    //   SPDX-license-identifier-GPL-2.0
     default_visibility: ["//visibility:private"],
     default_applicable_licenses: ["external_openwrt-prebuilts_license"],
 }
 
-// Added automatically by a large-scale-change that took the approach of
-// 'apply every license found to every target'. While this makes sure we respect
-// every license restriction, it may not be entirely correct.
-//
-// e.g. GPL in an MIT project might only apply to the contrib/ directory.
-//
-// Please consider splitting the single license below into multiple licenses,
-// taking care not to lose any license_kind information, and overriding the
-// default license using the 'licenses: [...]' property on targets as needed.
-//
-// For unused files, consider creating a 'fileGroup' with "//visibility:private"
-// to attach the license to, and including a comment whether the files may be
-// used in the current project.
-// See: http://go/android-license-faq
-license {
-    name: "external_openwrt-prebuilts_license",
-    visibility: [":__subpackages__"],
-    license_kinds: [
-        "SPDX-license-identifier-Apache-2.0",
-        "SPDX-license-identifier-BSD",
-        "SPDX-license-identifier-GPL-2.0",
-    ],
-    license_text: [
-        "LICENSE",
-    ],
-}
-
 filegroup {
     name: "openwrt_license_files",
     visibility: [":__subpackages__"],
@@ -40,7 +20,7 @@
 }
 
 license {
-    name: "openwrt_license",
+    name: "external_openwrt-prebuilts_license",
     visibility: [":__subpackages__"],
     license_kinds: [
         "SPDX-license-identifier-Apache-2.0",
@@ -50,9 +30,137 @@
         "SPDX-license-identifier-LGPL-2.1",
         "SPDX-license-identifier-MIT",
         "SPDX-license-identifier-ISC",
+        "SPDX-license-identifier-OpenSSL",
     ],
     license_text: [
         "LICENSE",
         "HOW_TO_GET_SOURCE_CODE",
     ],
 }
+
+genrule_defaults {
+    name: "openwrt_rootfs_base_defaults",
+    cmd: "cp $(in) $(genDir) && gzip -d $(genDir)/* && cp $(genDir)/* $(out)",
+}
+
+genrule {
+    name: "openwrt_rootfs_base_x86_64",
+    srcs: [
+        "x86_64/images/openwrt-22.03.3-x86-64-generic-squashfs-rootfs.img.gz",
+    ],
+    out: ["openwrt_rootfs_base_x86_64.img"],
+    defaults: ["openwrt_rootfs_base_defaults"],
+}
+
+genrule {
+    name: "openwrt_rootfs_base_aarch64",
+    srcs: [
+        "arm64/images/openwrt-22.03.3-armvirt-64-rootfs-squashfs.img.gz",
+    ],
+    out: ["openwrt_rootfs_base_aarch64.img"],
+    defaults: ["openwrt_rootfs_base_defaults"],
+}
+
+genrule_defaults {
+    name: "openwrt_rootfs_customization_defaults",
+    tools: [
+        "make_f2fs",
+        "sload_f2fs",
+    ],
+    srcs: [
+        ":openwrt_license_files",
+        "shared/uci-defaults/*",
+        "shared/config/*",
+    ],
+    cmd: "mkdir -p $(genDir)/root/upper/etc/uci-defaults && " +
+         "mkdir -p $(genDir)/root/upper/ipks && " +
+         "mkdir -p $(genDir)/root/upper/etc/config && " +
+         "cp $(in) $(genDir)/ && " +
+         "mv $(genDir)/*.ipk $(genDir)/root/upper/ipks && " +
+         "mv $(genDir)/LICENSE $(genDir)/HOW_TO_GET_SOURCE_CODE $(genDir)/INFO $(genDir)/root/upper && " +
+         "mv $(genDir)/0_default_config $(genDir)/root/upper/etc/uci-defaults && " +
+         "find $(genDir) -maxdepth 1 -type f -exec mv {} $(genDir)/root/upper/etc/config \\; && " +
+         "ln -s 2 $(genDir)/root/.fs_state && " +
+         "truncate -s 128M $(out) && " +
+         "$(location make_f2fs) $(out) && " +
+         "$(location sload_f2fs) -f $(genDir)/root -t / $(out)",
+}
+
+genrule {
+    name: "openwrt_rootfs_customization_x86_64",
+    srcs: [
+        "x86_64/kmods/*",
+        "x86_64/packages/*",
+        "x86_64/INFO",
+    ],
+    out: ["openwrt_rootfs_customization_x86_64.img"],
+    defaults: ["openwrt_rootfs_customization_defaults"],
+}
+
+genrule {
+    name: "openwrt_rootfs_customization_aarch64",
+    srcs: [
+        "arm64/kmods/*",
+        "arm64/packages/*",
+        "arm64/INFO",
+    ],
+    out: ["openwrt_rootfs_customization_aarch64.img"],
+    defaults: ["openwrt_rootfs_customization_defaults"],
+}
+
+genrule_defaults {
+    name: "openwrt_rootfs_combined_defaults",
+    tools: [
+        "append_squashfs_overlay",
+    ],
+    cmd: "$(location append_squashfs_overlay) $(in) $(out) -w",
+}
+
+genrule {
+    name: "openwrt_rootfs_combined_x86_64",
+    srcs: [
+        ":openwrt_rootfs_base_x86_64",
+        ":openwrt_rootfs_customization_x86_64",
+    ],
+    out: ["openwrt_rootfs_combined_x86_64.img"],
+    defaults: ["openwrt_rootfs_combined_defaults"],
+
+}
+
+genrule {
+    name: "openwrt_rootfs_combined_aarch64",
+    srcs: [
+        ":openwrt_rootfs_base_aarch64",
+        ":openwrt_rootfs_customization_aarch64",
+    ],
+    out: ["openwrt_rootfs_combined_aarch64.img"],
+    defaults: ["openwrt_rootfs_combined_defaults"],
+}
+
+prebuilt_etc_host {
+    name: "openwrt_rootfs_x86_64",
+    src: ":openwrt_rootfs_combined_x86_64",
+    sub_dir: "openwrt/images",
+    visibility: ["//device/google/cuttlefish/build"],
+}
+
+prebuilt_etc_host {
+    name: "openwrt_rootfs_aarch64",
+    src: ":openwrt_rootfs_combined_aarch64",
+    sub_dir: "openwrt/images",
+    visibility: ["//device/google/cuttlefish/build"],
+}
+
+prebuilt_etc_host {
+    name: "openwrt_kernel_x86_64",
+    src: "x86_64/images/openwrt-22.03.3-x86-64-generic-kernel.bin",
+    sub_dir: "openwrt/images",
+    visibility: ["//device/google/cuttlefish/build"],
+}
+
+prebuilt_etc_host {
+    name: "openwrt_kernel_aarch64",
+    src: "arm64/images/openwrt-22.03.3-armvirt-64-Image",
+    sub_dir: "openwrt/images",
+    visibility: ["//device/google/cuttlefish/build"],
+}
diff --git a/LICENSE b/LICENSE
index f62a027..c07a18b 100644
--- a/LICENSE
+++ b/LICENSE
@@ -12,6 +12,8 @@
 luci-theme-bootstrap
 rpcd-mod-luci
 rpcd-mod-rrdns
+luci-mode-rpc
+luci-lib-json
 
 Apache License
 
@@ -259,6 +261,22 @@
 kmod-cfg80211
 kmod-mac80211
 kmod-mac80211-hwsim
+iwinfo
+kmod-crypto-aead
+kmod-crypto-ccm
+kmod-crypto-cmac
+kmod-crypto-crc32c
+kmod-crypto-ctr
+kmod-crypto-gcm
+kmod-crypto-gf128
+kmod-crypto-ghash
+kmod-crypto-hash
+kmod-crypto-hmac
+kmod-crypto-manager
+kmod-crypto-null
+kmod-crypto-rng
+kmod-crypto-seqiv
+kmod-crypto-sha256
 
                     GNU GENERAL PUBLIC LICENSE
                        Version 2, June 1991
@@ -542,7 +560,7 @@
 
 ------------------------
 
-hostapd
+hostapd-openssl
 hostapd-common
 urngd
 
@@ -1802,3 +1820,124 @@
 OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
 SOFTWARE.
 
+------------------------------------------
+
+libopenssl1.1
+
+  OpenSSL License
+  ---------------
+
+/* ====================================================================
+ * Copyright (c) 1998-2019 The OpenSSL Project.  All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * 1. Redistributions of source code must retain the above copyright
+ *    notice, this list of conditions and the following disclaimer.
+ *
+ * 2. Redistributions in binary form must reproduce the above copyright
+ *    notice, this list of conditions and the following disclaimer in
+ *    the documentation and/or other materials provided with the
+ *    distribution.
+ *
+ * 3. All advertising materials mentioning features or use of this
+ *    software must display the following acknowledgment:
+ *    "This product includes software developed by the OpenSSL Project
+ *    for use in the OpenSSL Toolkit. (http://www.openssl.org/)"
+ *
+ * 4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to
+ *    endorse or promote products derived from this software without
+ *    prior written permission. For written permission, please contact
+ *    openssl-core@openssl.org.
+ *
+ * 5. Products derived from this software may not be called "OpenSSL"
+ *    nor may "OpenSSL" appear in their names without prior written
+ *    permission of the OpenSSL Project.
+ *
+ * 6. Redistributions of any form whatsoever must retain the following
+ *    acknowledgment:
+ *    "This product includes software developed by the OpenSSL Project
+ *    for use in the OpenSSL Toolkit (http://www.openssl.org/)"
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY
+ * EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE OpenSSL PROJECT OR
+ * ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+ * NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+ * LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+ * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
+ * OF THE POSSIBILITY OF SUCH DAMAGE.
+ * ====================================================================
+ *
+ * This product includes cryptographic software written by Eric Young
+ * (eay@cryptsoft.com).  This product includes software written by Tim
+ * Hudson (tjh@cryptsoft.com).
+ *
+ */
+
+ Original SSLeay License
+ -----------------------
+
+/* Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)
+ * All rights reserved.
+ *
+ * This package is an SSL implementation written
+ * by Eric Young (eay@cryptsoft.com).
+ * The implementation was written so as to conform with Netscapes SSL.
+ *
+ * This library is free for commercial and non-commercial use as long as
+ * the following conditions are aheared to.  The following conditions
+ * apply to all code found in this distribution, be it the RC4, RSA,
+ * lhash, DES, etc., code; not just the SSL code.  The SSL documentation
+ * included with this distribution is covered by the same copyright terms
+ * except that the holder is Tim Hudson (tjh@cryptsoft.com).
+ *
+ * Copyright remains Eric Young's, and as such any Copyright notices in
+ * the code are not to be removed.
+ * If this package is used in a product, Eric Young should be given attribution
+ * as the author of the parts of the library used.
+ * This can be in the form of a textual message at program startup or
+ * in documentation (online or textual) provided with the package.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the copyright
+ *    notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ *    notice, this list of conditions and the following disclaimer in the
+ *    documentation and/or other materials provided with the distribution.
+ * 3. All advertising materials mentioning features or use of this software
+ *    must display the following acknowledgement:
+ *    "This product includes cryptographic software written by
+ *     Eric Young (eay@cryptsoft.com)"
+ *    The word 'cryptographic' can be left out if the rouines from the library
+ *    being used are not cryptographic related :-).
+ * 4. If you include any Windows specific code (or a derivative thereof) from
+ *    the apps directory (application code) you must include an acknowledgement:
+ *    "This product includes software written by Tim Hudson (tjh@cryptsoft.com)"
+ *
+ * THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED.  IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ *
+ * The licence and distribution terms for any publically available version or
+ * derivative of this code cannot be changed.  i.e. this code cannot simply be
+ * copied and put under another distribution licence
+ * [including the GNU Public Licence.]
+ */
+
diff --git a/METADATA b/METADATA
index 9dfa57f..c2f2d0b 100644
--- a/METADATA
+++ b/METADATA
@@ -10,9 +10,9 @@
   }
   url {
     type: ARCHIVE
-    value: "https://downloads.openwrt.org/releases/21.02.0-rc3/"
+    value: "https://downloads.openwrt.org/releases/22.03.3/"
   }
-  version: "21.02.0-rc3 "
-  last_upgrade_date { year: 2021 month: 8 day: 4 }
+  version: "22.03.3"
+  last_upgrade_date { year: 2023 month: 1 day: 5 }
   license_type: RESTRICTED
 }
diff --git a/TEST_MAPPING b/TEST_MAPPING
new file mode 100644
index 0000000..aea06ad
--- /dev/null
+++ b/TEST_MAPPING
@@ -0,0 +1,12 @@
+{
+  "presubmit-large": [
+    {
+      "name": "CtsWifiTestCases",
+      "options": [
+        {
+          "exclude-annotation": "android.net.wifi.cts.VirtualDeviceNotSupported"
+        }
+      ]
+    }
+  ]
+}
diff --git a/arm64/INFO b/arm64/INFO
new file mode 100644
index 0000000..b9a33b2
--- /dev/null
+++ b/arm64/INFO
@@ -0,0 +1 @@
+arch: armvirt_64
diff --git a/arm64/images/openwrt-22.03.3-armvirt-64-Image b/arm64/images/openwrt-22.03.3-armvirt-64-Image
new file mode 100644
index 0000000..ea871ca
--- /dev/null
+++ b/arm64/images/openwrt-22.03.3-armvirt-64-Image
Binary files differ
diff --git a/arm64/images/openwrt-22.03.3-armvirt-64-rootfs-squashfs.img.gz b/arm64/images/openwrt-22.03.3-armvirt-64-rootfs-squashfs.img.gz
new file mode 100644
index 0000000..e2e41d6
--- /dev/null
+++ b/arm64/images/openwrt-22.03.3-armvirt-64-rootfs-squashfs.img.gz
Binary files differ
diff --git a/arm64/kmods/kmod-cfg80211_5.10.161+5.15.81-1-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-cfg80211_5.10.161+5.15.81-1-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..e06e17e
--- /dev/null
+++ b/arm64/kmods/kmod-cfg80211_5.10.161+5.15.81-1-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-aead_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-aead_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..78b5052
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-aead_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-ccm_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-ccm_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..d80f9b2
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-ccm_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-cmac_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-cmac_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..ba04a9a
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-cmac_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-crc32c_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-crc32c_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..0086615
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-crc32c_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-ctr_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-ctr_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..d948dd8
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-ctr_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-gcm_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-gcm_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..ed3b747
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-gcm_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-gf128_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-gf128_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..1ba6e9f
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-gf128_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-ghash_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-ghash_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..4025f41
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-ghash_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-hash_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-hash_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..9f10162
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-hash_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-hmac_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-hmac_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..5329958
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-hmac_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-manager_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-manager_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..f35fafa
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-manager_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-null_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-null_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..7a6c6d5
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-null_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-rng_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-rng_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..5fa847b
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-rng_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-seqiv_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-seqiv_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..f479bfa
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-seqiv_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-crypto-sha256_5.10.161-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-sha256_5.10.161-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..c53410b
--- /dev/null
+++ b/arm64/kmods/kmod-crypto-sha256_5.10.161-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-mac80211-hwsim_5.10.161+5.15.81-1-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-mac80211-hwsim_5.10.161+5.15.81-1-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..3d0c80e
--- /dev/null
+++ b/arm64/kmods/kmod-mac80211-hwsim_5.10.161+5.15.81-1-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/kmods/kmod-mac80211_5.10.161+5.15.81-1-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-mac80211_5.10.161+5.15.81-1-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..d1fa18e
--- /dev/null
+++ b/arm64/kmods/kmod-mac80211_5.10.161+5.15.81-1-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/packages/hostapd-common_2022-01-16-cff80b4f-15.2_aarch64_cortex-a53.ipk b/arm64/packages/hostapd-common_2022-01-16-cff80b4f-15.2_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..700f62d
--- /dev/null
+++ b/arm64/packages/hostapd-common_2022-01-16-cff80b4f-15.2_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/packages/hostapd-openssl_2022-01-16-cff80b4f-15.2_aarch64_cortex-a53.ipk b/arm64/packages/hostapd-openssl_2022-01-16-cff80b4f-15.2_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..bf670dd
--- /dev/null
+++ b/arm64/packages/hostapd-openssl_2022-01-16-cff80b4f-15.2_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/packages/iw_5.16-1_aarch64_cortex-a53.ipk b/arm64/packages/iw_5.16-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..a8737e7
--- /dev/null
+++ b/arm64/packages/iw_5.16-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/packages/iwinfo_2022-12-15-8d158096-1_aarch64_cortex-a53.ipk b/arm64/packages/iwinfo_2022-12-15-8d158096-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..3cfca4a
--- /dev/null
+++ b/arm64/packages/iwinfo_2022-12-15-8d158096-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/packages/libopenssl1.1_1.1.1s-1_aarch64_cortex-a53.ipk b/arm64/packages/libopenssl1.1_1.1.1s-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..47be3ed
--- /dev/null
+++ b/arm64/packages/libopenssl1.1_1.1.1s-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/packages/libubus20220601_2022-06-01-2bebf93c-1_aarch64_cortex-a53.ipk b/arm64/packages/libubus20220601_2022-06-01-2bebf93c-1_aarch64_cortex-a53.ipk
new file mode 100644
index 0000000..ea0fee0
--- /dev/null
+++ b/arm64/packages/libubus20220601_2022-06-01-2bebf93c-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm64/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk b/arm64/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk
new file mode 100644
index 0000000..1bfacaa
--- /dev/null
+++ b/arm64/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk
Binary files differ
diff --git a/arm64/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk b/arm64/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk
new file mode 100644
index 0000000..a60ed63
--- /dev/null
+++ b/arm64/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk
Binary files differ
diff --git a/arm64/packages/wireless-regdb_2022.08.12-1_all.ipk b/arm64/packages/wireless-regdb_2022.08.12-1_all.ipk
new file mode 100644
index 0000000..2fb08c3
--- /dev/null
+++ b/arm64/packages/wireless-regdb_2022.08.12-1_all.ipk
Binary files differ
diff --git a/x86/config/dhcp b/shared/config/dhcp
similarity index 81%
rename from x86/config/dhcp
rename to shared/config/dhcp
index e93f8f6..f994bbe 100644
--- a/x86/config/dhcp
+++ b/shared/config/dhcp
@@ -39,8 +39,14 @@
 	option leasetrigger '/usr/sbin/odhcpd-update'
 	option loglevel '4'
 
-config 'dhcp' 'wifi'
-	option 'interface' 'wifi'
-	option 'start' '100'
-	option 'limit' '150'
-	option 'leasetime' '12h'
+config dhcp 'wifi0'
+	option interface 'wifi0'
+	option start '100'
+	option limit '150'
+	option leasetime '12h'
+
+config dhcp 'wifi1'
+	option interface 'wifi1'
+	option start '100'
+	option limit '150'
+	option leasetime '12h'
diff --git a/x86/config/firewall b/shared/config/firewall
similarity index 89%
rename from x86/config/firewall
rename to shared/config/firewall
index 8c936ed..a1d9369 100644
--- a/x86/config/firewall
+++ b/shared/config/firewall
@@ -5,16 +5,26 @@
 	option forward 'REJECT'
 
 config zone
-	option name wifi
-	list network 'wifi'
-	option input ACCEPT
-	option output ACCEPT
-	option forward REJECT
+	option name 'wifi0'
+	list network 'wifi0'
+	option input 'ACCEPT'
+	option output 'ACCEPT'
+	option forward 'REJECT'
 
-config 'forwarding'
-	option 'src' 'wifi'
-	option 'dest' 'wan'
+config forwarding
+	option src 'wifi0'
+	option dest 'wan'
 
+config zone
+	option name 'wifi1'
+	list network 'wifi1'
+	option input 'ACCEPT'
+	option output 'ACCEPT'
+	option forward 'REJECT'
+
+config forwarding
+	option src 'wifi1'
+	option dest 'wan'
 
 config zone
 	option name 'lan'
diff --git a/shared/config/network b/shared/config/network
new file mode 100644
index 0000000..4f15042
--- /dev/null
+++ b/shared/config/network
@@ -0,0 +1,49 @@
+config interface 'loopback'
+	option device 'lo'
+	option proto 'static'
+	option ipaddr '127.0.0.1'
+	option netmask '255.0.0.0'
+
+config globals 'globals'
+	option ula_prefix 'fd72:5afb:a7cf::/48'
+
+config device
+	option name 'br-lan'
+	option type 'bridge'
+	list ports 'eth0'
+
+config device
+	option name 'br-wifi0'
+	option type 'bridge'
+	list ports 'eth0.0'
+
+config device
+	option name 'br-wifi1'
+	option type 'bridge'
+	list ports 'eth0.1'
+
+config device
+	option name 'eth0.0'
+	option macaddr '28:80:88:2A:6D:01'
+
+config device
+	option name 'eth0.1'
+	option macaddr '28:80:88:2A:6D:02'
+
+config interface 'wan'
+	option device 'br-lan'
+	option proto 'static'
+	option ip6assign '30'
+	option dns '8.8.8.8'
+
+config interface 'wifi0'
+	option device 'br-wifi0'
+	option proto 'static'
+	option netmask '255.255.255.128'
+	option ipaddr '192.168.99.1'
+
+config interface 'wifi1'
+	option device 'br-wifi1'
+	option proto 'static'
+	option netmask '255.255.255.128'
+	option ipaddr '192.168.99.129'
diff --git a/shared/config/system b/shared/config/system
new file mode 100644
index 0000000..269b7f7
--- /dev/null
+++ b/shared/config/system
@@ -0,0 +1,15 @@
+config system
+	option hostname 'OpenWrt'
+	option timezone 'UTC'
+	option ttylogin '0'
+	option log_size '64'
+	option urandom_seed '0'
+	option log_file '/dev/hvc0'
+
+config timeserver 'ntp'
+	option enabled '1'
+	option enable_server '0'
+	list server '0.openwrt.pool.ntp.org'
+	list server '1.openwrt.pool.ntp.org'
+	list server '2.openwrt.pool.ntp.org'
+	list server '3.openwrt.pool.ntp.org'
diff --git a/shared/config/wireless b/shared/config/wireless
new file mode 100644
index 0000000..7152192
--- /dev/null
+++ b/shared/config/wireless
@@ -0,0 +1,29 @@
+config wifi-device 'radio0'
+	option type 'mac80211'
+	option channel '36'
+	option band '5g'
+	option path 'virtual/mac80211_hwsim/hwsim0'
+	option htmode 'VHT80'
+	option disabled '0'
+
+config wifi-iface 'default_radio0'
+	option device 'radio0'
+	option mode 'ap'
+	option encryption 'none'
+	option network 'wifi0'
+	option ssid 'VirtWifi'
+
+config wifi-device 'radio1'
+	option type 'mac80211'
+	option channel '36'
+	option band '5g'
+	option path 'virtual/mac80211_hwsim/hwsim1'
+	option htmode 'VHT80'
+	option disabled '0'
+
+config wifi-iface 'default_radio1'
+	option device 'radio1'
+	option mode 'ap'
+	option encryption 'none'
+	option network 'wifi1'
+	option ssid 'VirtWifi2'
diff --git a/shared/uci-defaults/0_default_config b/shared/uci-defaults/0_default_config
new file mode 100644
index 0000000..deeac1f
--- /dev/null
+++ b/shared/uci-defaults/0_default_config
@@ -0,0 +1,37 @@
+#!/bin/sh
+
+opkg install /ipks/*
+ip link set eth0 mtu 1460
+
+rule_name=$(uci add network rule)
+
+# Extract configs from /proc/cmdline
+bridged_wifi_tap=false
+words=$(cat /proc/cmdline)
+while
+    word=${words%%" "*}
+    if [ "$word" = "bridged_wifi_tap=true" ]; then
+        bridged_wifi_tap=true
+    elif echo "$word" | grep "^wan_gateway="; then
+        uci set network.wan.gateway=${word#*"="}
+    elif echo "$word" | grep "^wan_ipaddr="; then
+        uci set network.wan.ipaddr=${word#*"="}
+    elif echo "$word" | grep "^wan_broadcast="; then
+        uci set network.wan.broadcast=${word#*"="}
+    fi
+    next=${words#*" "}
+    [ "$words" != "$next" ]
+do
+    words=$next
+done
+
+if $bridged_wifi_tap; then
+    uci set network.wan.netmask="255.255.255.0"
+else
+    uci set network.wan.netmask="255.255.255.252"
+fi
+
+uci commit
+
+# Regarding hostapd issue of OpenWRT 22.03.X versions, reboot it.
+reboot
diff --git a/x86/Android.bp b/x86/Android.bp
deleted file mode 100644
index a477379..0000000
--- a/x86/Android.bp
+++ /dev/null
@@ -1,74 +0,0 @@
-package {
-    // See: http://go/android-license-faq
-    // A large-scale-change added 'default_applicable_licenses' to import
-    // all of the 'license_kinds' from "openwrt_license"
-    // to get the below license kinds:
-    //   SPDX-license-identifier-Apache-2.0
-    //   SPDX-license-identifier-BSD
-    //   SPDX-license-identifier-GPL-2.0
-    default_applicable_licenses: ["openwrt_license"],
-}
-
-genrule {
-    name: "openwrt_customization",
-    tools: [
-        "make_f2fs",
-        "sload_f2fs",
-    ],
-    srcs: [
-        ":openwrt_license_files",
-        "kmods/*",
-        "packages/*",
-        "uci-defaults/*",
-        "config/*",
-    ],
-    out: ["customization.img"],
-    cmd: "mkdir -p $(genDir)/root/upper/etc/uci-defaults && " +
-         "mkdir -p $(genDir)/root/upper/ipks && " +
-         "mkdir -p $(genDir)/root/upper/etc/config && " +
-         "cp $(in) $(genDir)/ && " +
-         "mv $(genDir)/*.ipk $(genDir)/root/upper/ipks && " +
-         "mv $(genDir)/LICENSE $(genDir)/HOW_TO_GET_SOURCE_CODE $(genDir)/root/upper && " +
-         "mv $(genDir)/0_default_config $(genDir)/root/upper/etc/uci-defaults && " +
-         "find $(genDir) -maxdepth 1 -type f -exec mv {} $(genDir)/root/upper/etc/config \\; && " +
-         "ln -s 2 $(genDir)/root/.fs_state && " +
-         "truncate -s 128M $(out) && " +
-         "$(location make_f2fs) $(out) && " +
-         "$(location sload_f2fs) -f $(genDir)/root -t / $(out)",
-}
-
-genrule {
-    name: "openwrt_rootfs_base_img",
-    srcs: [
-        "images/openwrt-21.02.0-x86-64-generic-squashfs-rootfs.img.gz",
-    ],
-    out: ["base_rootfs.img"],
-    cmd: "cp $(in) $(genDir) && gzip -d $(genDir)/* && cp $(genDir)/* $(out)",
-}
-
-genrule {
-    name: "combined_openwrt_rootfs",
-    tools: [
-        "append_squashfs_overlay",
-    ],
-    srcs: [
-        ":openwrt_rootfs_base_img",
-        ":openwrt_customization",
-    ],
-    out: ["openwrt_rootfs.img"],
-    cmd: "$(location append_squashfs_overlay) $(in) $(out) -w",
-}
-
-prebuilt_etc_host {
-    name: "openwrt_rootfs",
-    src: ":combined_openwrt_rootfs",
-    sub_dir: "openwrt/images",
-    visibility: ["//device/google/cuttlefish/build"],
-}
-
-prebuilt_etc_host {
-    name: "kernel_for_openwrt",
-    src: "images/openwrt-21.02.0-x86-64-generic-kernel.bin",
-    sub_dir: "openwrt/images",
-    visibility: ["//device/google/cuttlefish/build"],
-}
diff --git a/x86/config/network b/x86/config/network
deleted file mode 100644
index e342f53..0000000
--- a/x86/config/network
+++ /dev/null
@@ -1,28 +0,0 @@
-config interface 'loopback'
-	option device 'lo'
-	option proto 'static'
-	option ipaddr '127.0.0.1'
-	option netmask '255.0.0.0'
-
-config globals 'globals'
-	option ula_prefix 'fd72:5afb:a7cf::/48'
-
-config device
-	option name 'br-lan'
-	option type 'bridge'
-	list ports 'eth0'
-
-config interface 'wan'
-	option device 'br-lan'
-	option proto 'static'
-	option netmask '255.255.255.0'
-	option ipaddr '192.168.96.2'
-	option ip6assign '30'
-	option gateway '192.168.96.1'
-	option dns '8.8.8.8'
-	option broadcast '192.168.96.3'
-
-config 'interface' 'wifi'
-	option 'proto' 'static'
-	option 'ipaddr' '192.168.2.1'
-	option 'netmask' '255.255.255.0'
diff --git a/x86/config/wireless b/x86/config/wireless
deleted file mode 100644
index aadcb99..0000000
--- a/x86/config/wireless
+++ /dev/null
@@ -1,14 +0,0 @@
-config wifi-device 'radio0'
-	option type 'mac80211'
-	option channel '36'
-	option hwmode '11a'
-	option path 'virtual/mac80211_hwsim/hwsim0'
-	option htmode 'VHT80'
-	option disabled '0'
-
-config wifi-iface 'default_radio0'
-	option device 'radio0'
-	option mode 'ap'
-	option encryption 'none'
-	option network 'wifi'
-	option ssid 'VirtWifi'
diff --git a/x86/images/openwrt-21.02.0-x86-64-generic-kernel.bin b/x86/images/openwrt-21.02.0-x86-64-generic-kernel.bin
deleted file mode 100644
index 6b12d15..0000000
--- a/x86/images/openwrt-21.02.0-x86-64-generic-kernel.bin
+++ /dev/null
Binary files differ
diff --git a/x86/images/openwrt-21.02.0-x86-64-generic-squashfs-rootfs.img.gz b/x86/images/openwrt-21.02.0-x86-64-generic-squashfs-rootfs.img.gz
deleted file mode 100644
index cf172fe..0000000
--- a/x86/images/openwrt-21.02.0-x86-64-generic-squashfs-rootfs.img.gz
+++ /dev/null
Binary files differ
diff --git a/x86/kmods/kmod-cfg80211_5.4.143+5.10.42-1-1_x86_64.ipk b/x86/kmods/kmod-cfg80211_5.4.143+5.10.42-1-1_x86_64.ipk
deleted file mode 100644
index 35e8dd0..0000000
--- a/x86/kmods/kmod-cfg80211_5.4.143+5.10.42-1-1_x86_64.ipk
+++ /dev/null
Binary files differ
diff --git a/x86/kmods/kmod-mac80211-hwsim_5.4.143+5.10.42-1-1_x86_64.ipk b/x86/kmods/kmod-mac80211-hwsim_5.4.143+5.10.42-1-1_x86_64.ipk
deleted file mode 100644
index 4a2339c..0000000
--- a/x86/kmods/kmod-mac80211-hwsim_5.4.143+5.10.42-1-1_x86_64.ipk
+++ /dev/null
Binary files differ
diff --git a/x86/kmods/kmod-mac80211_5.4.143+5.10.42-1-1_x86_64.ipk b/x86/kmods/kmod-mac80211_5.4.143+5.10.42-1-1_x86_64.ipk
deleted file mode 100644
index 437b555..0000000
--- a/x86/kmods/kmod-mac80211_5.4.143+5.10.42-1-1_x86_64.ipk
+++ /dev/null
Binary files differ
diff --git a/x86/packages/hostapd-common_2020-06-08-5a8b3662-35_x86_64.ipk b/x86/packages/hostapd-common_2020-06-08-5a8b3662-35_x86_64.ipk
deleted file mode 100644
index 3ce9314..0000000
--- a/x86/packages/hostapd-common_2020-06-08-5a8b3662-35_x86_64.ipk
+++ /dev/null
Binary files differ
diff --git a/x86/packages/hostapd_2020-06-08-5a8b3662-35_x86_64.ipk b/x86/packages/hostapd_2020-06-08-5a8b3662-35_x86_64.ipk
deleted file mode 100644
index 81a2268..0000000
--- a/x86/packages/hostapd_2020-06-08-5a8b3662-35_x86_64.ipk
+++ /dev/null
Binary files differ
diff --git a/x86/packages/iw_5.9-8fab0c9e-1_x86_64.ipk b/x86/packages/iw_5.9-8fab0c9e-1_x86_64.ipk
deleted file mode 100644
index 20b31f5..0000000
--- a/x86/packages/iw_5.9-8fab0c9e-1_x86_64.ipk
+++ /dev/null
Binary files differ
diff --git a/x86/packages/libubus20210630_2021-06-30-4fc532c8-2_x86_64.ipk b/x86/packages/libubus20210630_2021-06-30-4fc532c8-2_x86_64.ipk
deleted file mode 100644
index 5800017..0000000
--- a/x86/packages/libubus20210630_2021-06-30-4fc532c8-2_x86_64.ipk
+++ /dev/null
Binary files differ
diff --git a/x86/packages/wireless-regdb_2021.04.21-1_all.ipk b/x86/packages/wireless-regdb_2021.04.21-1_all.ipk
deleted file mode 100644
index 003cc26..0000000
--- a/x86/packages/wireless-regdb_2021.04.21-1_all.ipk
+++ /dev/null
Binary files differ
diff --git a/x86/uci-defaults/0_default_config b/x86/uci-defaults/0_default_config
deleted file mode 100644
index ff068df..0000000
--- a/x86/uci-defaults/0_default_config
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-opkg install /ipks/*
-ip link set eth0 mtu 1460
diff --git a/x86_64/INFO b/x86_64/INFO
new file mode 100644
index 0000000..c2409f5
--- /dev/null
+++ b/x86_64/INFO
@@ -0,0 +1 @@
+arch: x86_64
diff --git a/x86_64/images/openwrt-22.03.3-x86-64-generic-kernel.bin b/x86_64/images/openwrt-22.03.3-x86-64-generic-kernel.bin
new file mode 100644
index 0000000..624f9b4
--- /dev/null
+++ b/x86_64/images/openwrt-22.03.3-x86-64-generic-kernel.bin
Binary files differ
diff --git a/x86_64/images/openwrt-22.03.3-x86-64-generic-squashfs-rootfs.img.gz b/x86_64/images/openwrt-22.03.3-x86-64-generic-squashfs-rootfs.img.gz
new file mode 100644
index 0000000..d1b3c7f
--- /dev/null
+++ b/x86_64/images/openwrt-22.03.3-x86-64-generic-squashfs-rootfs.img.gz
Binary files differ
diff --git a/x86_64/kmods/kmod-cfg80211_5.10.161+5.15.81-1-1_x86_64.ipk b/x86_64/kmods/kmod-cfg80211_5.10.161+5.15.81-1-1_x86_64.ipk
new file mode 100644
index 0000000..94a065f
--- /dev/null
+++ b/x86_64/kmods/kmod-cfg80211_5.10.161+5.15.81-1-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-aead_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-aead_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..7fee426
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-aead_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-ccm_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-ccm_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..a3ebaa7
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-ccm_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-cmac_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-cmac_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..79f5b29
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-cmac_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-crc32c_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-crc32c_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..a0214a7
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-crc32c_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-ctr_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-ctr_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..02a4cfd
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-ctr_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-gcm_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-gcm_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..f788bd3
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-gcm_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-gf128_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-gf128_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..5c861d2
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-gf128_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-ghash_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-ghash_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..83b8ca9
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-ghash_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-hash_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-hash_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..68a5fc3
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-hash_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-hmac_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-hmac_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..51ea2ac
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-hmac_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-manager_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-manager_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..bfb583c
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-manager_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-null_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-null_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..95c5d94
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-null_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-rng_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-rng_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..07cc84e
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-rng_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-seqiv_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-seqiv_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..9ae7026
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-seqiv_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-crypto-sha256_5.10.161-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-sha256_5.10.161-1_x86_64.ipk
new file mode 100644
index 0000000..84cfa3c
--- /dev/null
+++ b/x86_64/kmods/kmod-crypto-sha256_5.10.161-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-mac80211-hwsim_5.10.161+5.15.81-1-1_x86_64.ipk b/x86_64/kmods/kmod-mac80211-hwsim_5.10.161+5.15.81-1-1_x86_64.ipk
new file mode 100644
index 0000000..7c36be2
--- /dev/null
+++ b/x86_64/kmods/kmod-mac80211-hwsim_5.10.161+5.15.81-1-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/kmods/kmod-mac80211_5.10.161+5.15.81-1-1_x86_64.ipk b/x86_64/kmods/kmod-mac80211_5.10.161+5.15.81-1-1_x86_64.ipk
new file mode 100644
index 0000000..95074e7
--- /dev/null
+++ b/x86_64/kmods/kmod-mac80211_5.10.161+5.15.81-1-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/packages/hostapd-common_2022-01-16-cff80b4f-15.2_x86_64.ipk b/x86_64/packages/hostapd-common_2022-01-16-cff80b4f-15.2_x86_64.ipk
new file mode 100644
index 0000000..79a3139
--- /dev/null
+++ b/x86_64/packages/hostapd-common_2022-01-16-cff80b4f-15.2_x86_64.ipk
Binary files differ
diff --git a/x86_64/packages/hostapd-openssl_2022-01-16-cff80b4f-15.2_x86_64.ipk b/x86_64/packages/hostapd-openssl_2022-01-16-cff80b4f-15.2_x86_64.ipk
new file mode 100644
index 0000000..d2d7b58
--- /dev/null
+++ b/x86_64/packages/hostapd-openssl_2022-01-16-cff80b4f-15.2_x86_64.ipk
Binary files differ
diff --git a/x86_64/packages/iw_5.16-1_x86_64.ipk b/x86_64/packages/iw_5.16-1_x86_64.ipk
new file mode 100644
index 0000000..0fa98f6
--- /dev/null
+++ b/x86_64/packages/iw_5.16-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/packages/iwinfo_2022-12-15-8d158096-1_x86_64.ipk b/x86_64/packages/iwinfo_2022-12-15-8d158096-1_x86_64.ipk
new file mode 100644
index 0000000..b43d30a
--- /dev/null
+++ b/x86_64/packages/iwinfo_2022-12-15-8d158096-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/packages/libopenssl1.1_1.1.1s-1_x86_64.ipk b/x86_64/packages/libopenssl1.1_1.1.1s-1_x86_64.ipk
new file mode 100644
index 0000000..77fab59
--- /dev/null
+++ b/x86_64/packages/libopenssl1.1_1.1.1s-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/packages/libubus20220601_2022-06-01-2bebf93c-1_x86_64.ipk b/x86_64/packages/libubus20220601_2022-06-01-2bebf93c-1_x86_64.ipk
new file mode 100644
index 0000000..8dc0043
--- /dev/null
+++ b/x86_64/packages/libubus20220601_2022-06-01-2bebf93c-1_x86_64.ipk
Binary files differ
diff --git a/x86_64/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk b/x86_64/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk
new file mode 100644
index 0000000..1bfacaa
--- /dev/null
+++ b/x86_64/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk
Binary files differ
diff --git a/x86_64/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk b/x86_64/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk
new file mode 100644
index 0000000..a60ed63
--- /dev/null
+++ b/x86_64/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk
Binary files differ
diff --git a/x86_64/packages/wireless-regdb_2022.08.12-1_all.ipk b/x86_64/packages/wireless-regdb_2022.08.12-1_all.ipk
new file mode 100644
index 0000000..2fb08c3
--- /dev/null
+++ b/x86_64/packages/wireless-regdb_2022.08.12-1_all.ipk
Binary files differ